Default Order is mal functioning

Even though I have selected “Investing” as default order, many a times it select “Trading” by default which cost me losses few times. Any solution for same.

Hey, Yes. We are in process of making this visually better. Have received the feedback from users, and work in progress.

Order type default is for sub-order types. Master order types today are: Investing, Trading, MTF, Normal and Positional. They are defined on scripts at the Order Management / Risk Management levels.

1 Like

When will you fix it.
I always save defult order as “investing” but it keeps going to “intraday” setting. Today again I lot lomney beccause of this.
Take some clue from AngelOne, when they have made is really correct.

And yar, for god sake, fix things quickly… One month on this issue and no response. …frustating…

You have such a beautiful interface, so many things are good, but they seems useless when basic stuff is not right…