Error: Trigger gap is out of the specified gap range

I am getting this error when I am trying to place a bracket limit order from tradingview. What am I doing wrong?


1 Like

Hi @Krishna Welcome to the community.
For Bracket Order & Cover Order, your Stop Loss Leg should have minimum 1% (0.3% in case of Index) of difference with LTP. For example- If LTP for a particular stock is 500, you should place your SL below 495.
Hope this helps

1 Like


In general, intraday traders use risk percentage as 2%. some members may use 3% also.
then giving 1% is not worth able, who trades on with trade plan.

hence consider this logic and increase the percentage.
so that we can trade as per our trade plan with strict stoploss and target.

1 Like

Hello @Naman @Dhan Team,

I’m trying to place the order with stoploss lessthan the Dhan stoploss recommending. Which is good for me as per my strategy.

But reducing risk and placing bracket order is my choice with risk planned.

Why is this condition implemented in Dhan?
If possible, kindly disable this option for bracket orders.


Hi @iyapaa,

It seems you have raised this multiple times. We will update you with the details over here.

It is not working, please make a video to learn how to place bracket order directly in tradingview

Hi @kiranauto

Kindly help us with more details about what difficulties you facing with the Bracket order please do connect with us at or call us at 022 - 4890 6273

At this moment the video is available for App and Web, for we have noted feedback on this

How To Place Bracket Order On Dhan? Do’s And Don’ts Explained | Dhan - YouTube

Hello @Krishna \Team,

Seems I found the reason for this error and work around. I was placing this order using API, and i have code to calculate minimum value for SL which is .25%. So, when i receive alert, and by the time it tries to place an order in exchange, the ticker price will move more in opposite direction and making the previous calculated SL .25% value to .24% or less, and so leading the error of specified gap.

Work around i did is that, in case, if my ATR is less than this minimum value, then it will auto pick this new SL of .3% (instead of .25%).

Hope this helps to address this issue.