Watchlist not working properly

I have been facing this problem for past 10-15 days that if my watchlist on contains some stocks and I use spacebar or down arrow key to move to the next scrip, it takes me to the first scrip, instead of the next one.

Again, it is happening in different browsers and different PCs/laptops randomly.

Hi @Shally,

As discussed over call, request you to kindly remove such scrip from your watchlist which is pushing back to the first scrip and try once.

Ma’am, it is happening random basis. Sometimes it happens with scrip x then next time scrip y. There is no particular order. So, this solution is not working as expected.

And this is happening for past few days only.

Hi @Shally,

We tried reaching you but unable to establish contact with you. This happens in rare scenario wherein symbol name are updated. In such case, we suggest you to remove and add all scrips again to watchlist.

The problem is as it is even after so many months.

Yesterday, created three new watchlists and deleted the old ones. The behaviour is still the same.

Here is one of my watchlists. The normal behaviour is that when we press spacebar, it moves to the next scrip but when it reaches β€œVarun Beverages” in the watchlist, it moves to the first scrip on pressing of spacebar. And this watchlist is created only yesterday.

Please check. This is very much annoying.

Same is happening in another watchlist. After the 4th stock i.e., DP Wires, the pressing of spacebar leads to the first scrip instead of the next one.

And the next behaviour occurs at Ramakrishna forgings.

And the next behaviour at Sandur Manganese (by the way, Sandur Manganese chart is not showing any data)

Hi @Shally

We are having this check, please allow us some time, and we will get back to you shortly.

Hi @Divyesh, hope the team is looking into the issue.

Hi @Shally,

Request you to kindly try now, let us know if you are still facing this issue.

Hi @Poornima,

Went through all the watchlists again, situation is same as before.


Hi @Shally,

We are reviewing this, will get back to you once resolved.

Agreeable, it happens regularly, have to use mouse to select ticker or find pattern for changing ticker using arrow, just like having short of customized keys.

Absolutely. Have to use mouse and the difficult part is you have to remember the scrip from where it jumped back to the first and then go to it again.

This problem/bug is for so long. I first reported it maybe an year back. I don’t know why other users have not reported it.

Hi @Shally Request you to kindly check your DM.

Replied you over there.

Hi @Shally

Thank you for highlighting your concerns. We have noted all your points, and we will review them and fix them very soon.


Some scrips in watchlist are not showing any data. Have a look:

(By the way, intraday data of Suzlon is also not appearing on charts)

Another watchlist:

There may have been some change on this script, can you remove and add this again to Watchlist.

And what about Suzlon?